Flash 8 Player is required.
Why North America Should Care